GIMP 2.8.14 on Yosemite Does Not Recognize Image File Types

Jeff Singleton gvibe06 at
Sun Oct 26 18:15:23 PDT 2014

On 10/26/14, 8:07 PM, Ryan Schmidt wrote:
> On Oct 26, 2014, at 6:52 PM, Jeff Singleton wrote:
>> On 10/26/14, 6:46 PM, Ryan Schmidt wrote:
>>> On Oct 26, 2014, at 6:37 PM, Jeff Singleton wrote:
>>>> Upgraded to Yosemite, and after reading through the problems people were
>>>> having, I opted to delete MacPorts and re-install everything. I did not
>>>> change anything other than forcing the variant +quartz, and I choose to
>>>> compile everything.
>>>> Gimp will launch from the command line, as well as, from the native
>>>> application bundle I make from the GIMPskel scripts.
>>>> What happens:
>>>> - Launch Gimp
>>>> - File -> Open
>>>> - Browse to my Pictures folder
>>>> - Inside the Open File window, in my Pictures Folder, no images
>>>> - Changing to All Files, shows images
>>>> - No previews are shown
>>>> - Try to open an image (png) and get Error: File Type Not Recognized
>>>> - Searched Google for general issues first
>>>> - Uninstalled Gimp, Gegl, and Babl
>>>> - Checked to make sure all Image libs are installed
>>>> - libpng, jpeg, libmng, tiff, giflib, jasper are all installed
>>>> - Recompiled Babl, Gegl, and Gimp
>>>> - Same results
>>>> /opt/local/lib/gimp/2.0/plug-ins does have all of the file-* files for
>>>> each of the image types.
>>>> /opt/local/etc/ contains what is expected, pango, gtk-2.0, and gimp with
>>>> all of the module, loader, and rc files.
>>>> From the command line I still see that DBUS error, and one other:
>>>>  Error spawning command line `launchctl getenv
>>>>  DBUS_LAUNCHD_SESSION_BUS_SOCKET': Child process killed by signal 11
>>>>  (gimp:27425): LibGimpBase-WARNING **: gimp: gimp_wire_read(): error
>>>> No other messages show up.
>>>> I have in the process of recompiling Gimp, deleted all .folders in my
>>>> home, as well as, ~/Library/Application Support/GIMP. To no avail, GIMP
>>>> still does not recognize anything except .xcf file types.
>>>> If this is a bug, is it on MacPorts, or is it something upstream?
>>> My first suspicion would be that using the +quartz variant may be responsible.
>>> Of course, undoing that selection is not so easy, since it may be any one of gimp's dependencies, and not just gimp itself, that needs to be rebuilt without the +quartz variant to fix this.
>> Aww man...don't say that. I hate the X11 way. I don't know why, it just
>> bugs me when X11 has to launch before launching any Apps that rely on
>> it. I don't mind recompiling everything, but I just can't bring myself
>> to use X11 on my Mac.
> I understand and feel the same way, but many projects don't test their Quartz mode as thoroughly, and it's not the default in MacPorts either, which adds up to there being issues sometimes, which is why it would be the first place I'd look as the culprit for the issue you're seeing. If you can confirm that, then you could report the bug to the developers. Well, you can and should report the problem to them in any case, but it may help them if you can isolate what's causing the problem.
>> Keep in mind, this only started on Yosemite. Everything worked great
>> under Mavericks.
> I thought you said you weren't using the +quartz variant on Mavericks?
> If the differences between when it worked and when it didn't work are 1) you upgraded from Mavericks to Yosemite, and 2) you switched to using the +quartz variant, then the latter is the change I'd most likely suspect.
> bad if I wasn't clear. I have always used +quartz, pretty much
since Snow Leopard...even venturing outside of MacPorts for a bit, by
manually download/compile/installing everything.

I am doing some rebuilds with keep_logs enabled and debugging enabled to
see if I can isolate things before jumping to recompiling.

I will reply again if I find anything and will use all of the info I
collect for my bug report.


More information about the macports-users mailing list