Error: Insufficient privileges to write to MacPorts install prefix.

Ludwig macports at
Thu Aug 6 23:38:41 PDT 2015

On Fri, 07 Aug 2015, Jim Mattingly wrote:

> Getting the above-referenced error code when attempting command: port install
> pspp, Have even tried sudo, although it is only a single-user computer at
> home, then sudo scolds me and asks for a password I don’t have. Downloaded
> Xcode from app store and macports, according to macports guide, and env
> command worked just fine, but both install and selfupdate commands tell me I
> don’t have the necessary privileges to run them. Simply running commands on
> apple terminal with Xcode open. Any ideas what to do? I’m perhaps a
> relatively advance user, but not an IT pro, so perhaps there is something
> simple I’m overlooking.  _______________________________________________

Sounds like you haven’t added yourself to sudoers. You may need to launch
Directory Utility and enable root; then use su to switch to the root account;
then run visudoers and add “[your short username]  ALL=(ALL) ALL” under the
User privilege specification section. 

Sudo should work for you after all that.

(Oh, and go back to Directory Utility and disable root. It’s a minor security
measure but it ain’t nothing.)

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 821 bytes
Desc: not available
URL: <>

More information about the macports-users mailing list