MacPorts and Clang

firetiti firetiti at
Fri Jul 17 01:33:35 PDT 2015


I just installed the Clang last version using « sudo port install clang-3.6 @3.6.1_1 », and it worked perfectly fine.
But when I check the current version « clang —version », I still have the old clang version.
I tried to modify /usr/bin/clang in order to make a symbolic link on « /opt/local/bin/clang-mp-3.6 », but then macport does not work anymore:
FiReTiTi ~ $ sudo port upgrade outdated
Error: Unable to open port: can't set "compiler.blacklist": couldn't determine build number of compiler "clang"
To report a bug, follow the instructions in the guide:

How can I do in order to have the last clang version as the current one?

Thank you for your help,

 - 22 - It’s only when a mosquito lands on your testicules that you realize there is always a way to solve problems without using violence (Chinese proverb?).

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the macports-users mailing list