Problem installing macports

Sepideh Razavi razavi.sepideh at
Mon Oct 12 07:17:09 PDT 2015

Hi Rainer,

Thanks for your response. When you brought up the tmp directory, I realized
that there must be an issue with the tmp on my Mac because I also had
experienced problems with attaching documents to my email. I did reboot the
computer but that didn't help so I went ahead and made the tmp directory in
root. I could get the macports "sudo make install" to work and then I ran
"sudo port -d self update" which was executed successfully. However, when I
tried to grab python 2.7 using macports, I ran into the following issue:

hawkeye:/ srazavi$ sudo port install cmake boost +python27 python_select

--->  Computing dependencies for cmake

--->  Dependencies to be installed: bzip2 curl curl-ca-bundle openssl zlib
expat libarchive libiconv libxml2 xz gettext ncurses lzo2

--->  Fetching archive for bzip2

--->  Attempting to fetch bzip2-1.0.6_0.darwin_14.x86_64.tbz2 from

--->  Attempting to fetch bzip2-1.0.6_0.darwin_14.x86_64.tbz2.rmd160 from

Warning: Failed to verify signature for archive!

Error: org.macports.archivefetch for port bzip2 returned: archivefetch
failed for bzip2 @1.0.6_0

Error: Failed to install bzip2

Please see the log file for port bzip2 for details:


Error: The following dependencies were not installed: bzip2 curl
curl-ca-bundle openssl zlib expat libarchive libiconv libxml2 xz gettext
ncurses lzo2

To report a bug, follow the instructions in the guide:

Error: Processing of port cmake failed

Any suggestions?

Thanks again!

Sepideh Razavi
Postdoctoral Research Fellow
North Campus Research Complex
University of Michigan
Ann Arbor, MI 48109
email: *srazavi** <> *

On Mon, Oct 12, 2015 at 9:35 AM, Rainer Müller <raimue at> wrote:

> On 2015-10-12 14:31, Sepideh Razavi wrote:
> > /opt/local/libexec/macports/bin/tclsh8.5
> > ./src/upgrade_sources_conf_default.tcl "/opt/local"
> >
> > couldn't create error file for command: no such file or directory
> >
> >     while executing
> >
> > "open "|$mktemp -t macports_sources_upgrade.XXXXXXXXXX" r"
> >
> >     invoked from within
> >
> > "set mktempChannel [open "|$mktemp -t
> > macports_sources_upgrade.XXXXXXXXXX" r]"
> >
> >     (file "./src/upgrade_sources_conf_default.tcl" line 33)
> >
> > make: *** [install] Error 1
> It looks the installation is unable to create temporary files.
> Maybe $TMPDIR points to a non-existent path?
> Reboot your machine. That should reset the temporary directory.
> Rainer
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the macports-users mailing list