Problem installing macports

Sepideh Razavi razavi.sepideh at
Mon Oct 12 10:38:39 PDT 2015

So I tried cleaning all the ports using  "port clean --all all" and it
didn't help. Also uninstalled macports and built it again from the source
but still get the same error no matter what port I am trying to install.
For instance when grabbing vim I get:

hawkeye:MacPorts-2.3.3 srazavi$ sudo port install vim

--->  Computing dependencies for vim

--->  Dependencies to be installed: gettext expat libiconv ncurses

--->  Fetching archive for expat

--->  Attempting to fetch expat-2.1.0_0.darwin_14.x86_64.tbz2 from

--->  Attempting to fetch expat-2.1.0_0.darwin_14.x86_64.tbz2.rmd160 from

Warning: Failed to verify signature for archive!

Error: org.macports.archivefetch for port expat returned: archivefetch
failed for expat @2.1.0_0

Error: Failed to install expat

Please see the log file for port expat for details:


Error: The following dependencies were not installed: gettext expat
libiconv ncurses

To report a bug, follow the instructions in the guide:

Error: Processing of port vim failed

One more thing to add is that I am still unable to install macports from
the package file but was able to install it through the source and update
it to version 2.3.4. I am not sure what is defective in my installed
macport that I can not grab any port using it. Any ideas?


Sepideh Razavi
Postdoctoral Research Fellow
North Campus Research Complex
University of Michigan
Ann Arbor, MI 48109
email: *srazavi** <> *

On Mon, Oct 12, 2015 at 11:33 AM, Ryan Schmidt <ryandesign at>

> On Oct 12, 2015, at 9:17 AM, Sepideh Razavi wrote:
> > hawkeye:/ srazavi$ sudo port install cmake boost +python27 python_select
> openmpi-default
> > --->  Computing dependencies for cmake
> > --->  Dependencies to be installed: bzip2 curl curl-ca-bundle openssl
> zlib expat libarchive libiconv libxml2 xz gettext ncurses lzo2
> > --->  Fetching archive for bzip2
> > --->  Attempting to fetch bzip2-1.0.6_0.darwin_14.x86_64.tbz2 from
> > --->  Attempting to fetch bzip2-1.0.6_0.darwin_14.x86_64.tbz2.rmd160
> from
> > Warning: Failed to verify signature for archive!
> Those files on the server haven't changed since November 2014, so I doubt
> they're the problem. Maybe clean the port and try again?
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the macports-users mailing list