Problem installing macports

Sepideh Razavi razavi.sepideh at
Tue Oct 13 04:55:04 PDT 2015

So I cleaned all the ports and uninstalled macports, then built again from
the source. Again run into signature verification failure step but this
time even at the self update step (where I had no issues before):

hawkeye:1-Analysis srazavi$ sudo port -v -d selfupdate

DEBUG: Copying /Users/srazavi/Library/Preferences/
to /opt/local/var/macports/home/Library/Preferences

DEBUG: MacPorts sources location: /opt/local/var/macports/sources/

--->  Updating MacPorts base sources using rsync

receiving file list ... done

sent 36 bytes  received 69 bytes  70.00 bytes/sec

total size is 27013120  speedup is 257267.81

receiving file list ... done

sent 36 bytes  received 76 bytes  224.00 bytes/sec

total size is 512  speedup is 4.57

DEBUG: failed verification with key

DEBUG: openssl output: Verification Failure

child process exited abnormally

DEBUG: Failed to verify signature for MacPorts source!

    while executing

"macports::selfupdate [array get global_options] base_updated"

Error: Failed to verify signature for MacPorts source!

To report a bug, follow the instructions in the guide:
Error: /opt/local/bin/port: port selfupdate failed: Failed to verify
signature for MacPorts source!


Sepideh Razavi
Postdoctoral Research Fellow
North Campus Research Complex
University of Michigan
Ann Arbor, MI 48109
email: *srazavi** <> *

On Mon, Oct 12, 2015 at 6:39 PM, Ryan Schmidt <ryandesign at>

> On Oct 12, 2015, at 12:38 PM, Sepideh Razavi wrote:
> > So I tried cleaning all the ports using  "port clean --all all" and it
> didn't help. Also uninstalled macports and built it again from the source
> but still get the same error no matter what port I am trying to install.
> For instance when grabbing vim I get:
> >
> > hawkeye:MacPorts-2.3.3 srazavi$ sudo port install vim
> > --->  Computing dependencies for vim
> > --->  Dependencies to be installed: gettext expat libiconv ncurses
> > --->  Fetching archive for expat
> > --->  Attempting to fetch expat-2.1.0_0.darwin_14.x86_64.tbz2 from
> > --->  Attempting to fetch expat-2.1.0_0.darwin_14.x86_64.tbz2.rmd160
> from
> > Warning: Failed to verify signature for archive!
> Can you use the debug flag (-d) to show us more about why the signature
> verification failed?
> sudo port -d install vim
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the macports-users mailing list