Get MacPorts to forget about my Fink install

Stephen J. Butler stephen.butler at
Wed Sep 30 14:16:11 PDT 2015

Nope, /sw is entirely gone.

On Wed, Sep 30, 2015 at 4:13 PM, David Strubbe <dstrubbe at>

> Does that file still exist?
> On Wed, Sep 30, 2015 at 5:09 PM, Stephen J. Butler <
> stephen.butler at> wrote:
>> Hi.
>> I'm transitioning from Fink to MacPorts. When I initially setup my
>> MacPorts install I *thought* I had removed all my Fink stuff from my path.
>> Everything was working and I was happy, so I deleted my /sw directory.
>> But now I see that the MacPorts build system has picked up /sw/bin/gnutar
>> (among, possibly, other things I haven't discovered). My upgrade of cctools
>> is failing because it is trying to use that to extract the source :/
>> I can't figure out how to get MacPorts to forget about that path. I tried
>> doing a "sudo port clean --all all" but that didn't help. Tried greping
>> through /opt/local/etc and /opt/local/var/macports for references to
>> "/sw/bin/gnutar" but didn't find any.  Not sure why it keeps going back to
>> /sw/bin/gnutar.
>> What have I missed? I hope I'm not going to have to re-install everything.
>> _______________________________________________
>> macports-users mailing list
>> macports-users at
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the macports-users mailing list