X11 and QD name space conflicts as they apply to webkit2-gtk on snowleopard

Ken Cunningham ken.cunningham.webuse at gmail.com
Mon Aug 15 15:15:51 PDT 2016

I'm attempting to build Epiphany on SnowLeopard with libc++ installed, as Snow Leopard has no up-to-date browser options available any longer.

Epiphany uses webkit2-gtk, and with some minor fixes, webkit2-gtk does build on snow leopard. But there are name space conflicts between X11 and QD, so as the webkit2-gtk code base stands now, the only way to build it is to disable X11 and build for quartz only.

Unfortunately, Epiphany pulls in gnome-desktop, which pulls in gtk3 +X11, and gnome-desktop appears to build only with X11 enabled. So catch-22.

I note upon cruising the web that this is a very old problem, which both Dave Evans and Jeremy appear to have worked on over the years, both in webkit and in xserver.


and more....

At various points, the bug is declared fixed, but it popped up again just now when I tried to build webkit2-gtk.

Does anyone have any advice on how to best proceed here? It appears that I need to find a way to build webkit2-gtk with +x11 to proceed. There is some code referenced above to santize QD types on xserver -- perhaps I could try to integrate that into webkit2-gtk.



More information about the macports-users mailing list