Problem with Macports on OS X 10.8

H.-Ulrich (Uli) Wienands wienands at
Fri Dec 23 16:36:21 CET 2016

I am trying to install octave on a Mac Pro running 10.8.(latest). I have 
Xcode 5.1.1 installed.

A bunch of deps is installed successfully but then it chokes.

I finally track this down to an inability to install any compilers (? 
that is what it appears to be).

Trying to build up from the bottom I install llvm 3.4, 3.5 etc. Works ok 
until I hit llvm-3.9. It appears llvm-3.
9 has itsels in its list of dependencies.

I made sure my Macports installaion was up-to-date (I installed it only 
a couple of weeks ago but still I updated everything) and tried to clean 
whatever would not install. No joy.

Here is the tail from the log of my atttempt to install llvm-3.9. Note 
that none of the clangs would install. And I never get an error message 
beyond "Installatino of ..." has failed. I also tried installing gcc46 
(which I have installed even on a fairly ancient on a 10.5 PPC system, 
no joy either.

Any hint would be appreciated.


:debug:main Sourcing PortGroup compiler_blacklist_versions 1.0 from 
:debug:main Sourcing PortGroup active_variants 1.1 from 
:debug:main Re-registering default for configure.dir
:debug:main Re-registering default for configure.pre_args
:debug:main Re-registering default for build.dir
:debug:main Re-registering default for
:debug:main Sourcing PortGroup cmake 1.0 from 
:debug:main Re-registering default for configure.dir
:debug:main Re-registering default for build.dir
:debug:main compiler clang 503.0.40 blacklisted because it matches 
{clang < 602}
:debug:main Reading variant descriptions from 
:debug:main universal variant already exists, so not adding the default one
:debug:main Running callback 
:debug:main Preferred compilers: clang macports-clang-3.8 
macports-clang-3.7 macports-clang-3.6 mac\
ports-clang-3.5 macports-clang-3.4 macports-llvm-gcc-4.2 apple-gcc-4.2
:debug:main Chosen compiler macports-clang-3.8 is provided by a port, 
adding dependency
:debug:main Adding depends_build port:clang-3.8
:debug:main Adding depends_skip_archcheck clang-3.8
:debug:main Finished running callback 
:debug:main Running callback 
:debug:main Finished running callback 
:info:main .:debug:main llvm-3.9 has no conflicts
:msg:main --->  Dependencies to be installed: clang-3.8 ld64 ld64-latest 
llvm-3.9 llvm-3.8 clang-3.\
:debug:main dlist_eval: all entries in dependency list have unsatisfied 
dependencies; can't process
:error:main The following dependencies were not installed: clang-3.8 
ld64 ld64-latest llvm-3.9 llvm\
-3.8 clang-3.7
:notice:main To report a bug, follow the instructions in the guide:
:error:main Processing of port llvm-3.9 failed

More information about the macports-users mailing list