Macports: install/uninstall failed?

Kishalay Choudhury kishalay1492 at
Thu Jun 9 23:20:47 PDT 2016

Hi Ryan,

I cleared the running processes by finding their PIDs with "ps -A | grep tclsh”, and then restarted my machine. Now Macports is working fine. Problem solved!


From: Ryan Schmidt <ryandesign at<mailto:ryandesign at>>
Sent: Friday, June 10, 2016 4:40:23 AM
To: Kishalay Choudhury
Cc: MacPorts Users
Subject: Re: Macports: install/uninstall failed?

On Jun 9, 2016, at 11:30 PM, Kishalay Choudhury wrote:

> I tried to install grace and openmotif for my Mac OSX Yosemite but it gives me the same message and sits there doing nothing for hours:
> Kishalays-MacBook-Air:grace-5.1.25 Kishalay$ port search motif
> openmotif @2.3.4_3 (x11)
>     The Open Motif toolkit for X11
> SoXt @1.2.2_2 (x11, graphics, devel)
>     Xt/Motif glue library for Coin
> vtwm @5.4.6b_1 (x11)
>     Twm with a virtual desktop and optional Motif-like features
> Found 3 ports.
> Kishalays-MacBook-Air:grace-5.1.25 Kishalay$ sudo port install openmotif
> Password:
> Waiting for lock on /opt/local/var/macports/registry/.registry.lock

"Waiting for lock" means you have another MacPorts installation running in another Terminal window.

If you do not, maybe MacPorts or your computer crashed or you forcibly restarted your computer while another MacPorts process was running. If so, you would have to manually clear the lock, but I'm not sure how to do that; maybe someone else knows.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the macports-users mailing list