Octave won't start, looks for legacy Java SE 6 runtime

Murray Eisenberg murrayeisenberg at gmail.com
Tue May 24 07:36:19 PDT 2016

I have octave installed with variants:

    octave @4.0.2_0+app+atlas+docs+fltk+gfortran+graphicsmagick+java+qt4gui+sound 

When I try to run octave from command line, I get pop-up window:

    ‘To open “this Java application” you need to
     install the legacy Java SE 6 runtime.”

Under OS X 10.11.5, I have Java JDK 1.8 (specifically, the current 1.8.0_91) and the corresponding Java runtime 1.8.

[While I know that I have Java 6 runtime actually present on my system, so it’s available to certain older apps that require it, the active Java runtime is Java 8 (1.8).]

Is the best course simply to remove the +java variant for octave, or will I lose some substantial functionality?

(I’m unsure why I installed with the +java variant in the first place!)
Murray Eisenberg			murrayeisenberg at gmail.com
503 King Farm Blvd #101	Home (240)-246-7240
Rockville, MD 20850-6667	Mobile (413)-427-5334

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.macosforge.org/pipermail/macports-users/attachments/20160524/bb1d15f2/attachment.html>

More information about the macports-users mailing list