X11 won't start

Langer, Stephen A. (Fed) stephen.langer at nist.gov
Tue Apr 4 14:27:00 UTC 2017

Hi --

I just updated my computer to Sierra, and now X11 won't start.  I presumed that I had messed up the macports migration, so I just uninstalled everything and installed only xorg-server and xterm, but I'm still getting the same error.  There's an "X11 quit unexpectedly" dialog, which keeps reappearing when dismissed.  I have to log out to get it to go away.  

System.log is filled with lines like "X[6012]: no path for address 0x1234567"

In case it's relevant, what I might have screwed up in the first migration was that I tried to install only the requested ports, which has worked for me in the past.  But this time I put them all on one line, and used -N so that port wouldn't ask me for permission to install the dependencies, and I could leave it to work on its own.  That ran into problems caused by https://trac.macports.org/ticket/49379.  It seemed to have installed xorg-libXt with +flat_namespace and then reinstalled it without it, or vice versa (both were installed but I forget which was active).  In any case, I uninstalled everything, installed xorg-libXt first, using +flat_namespace, and then installed all the other requested ports without -N so that I'd see if anything went wrong.  I didn't see any errors, but X11 wouldn't start.  This morning I tried installing only xorg-server and xterm, and it still won't start.

Why is X11 failing to start?  How can I keep it from attempting to start repeatedly, even after I've killed xterm or whatever other X11 app I'm using?  What might have I done wrong in the installation and how can I fix it?

Any suggestions would be appreciated!


-- Steve

More information about the macports-users mailing list