X11 won't start

Langer, Stephen A. (Fed) stephen.langer at nist.gov
Tue Apr 4 15:07:24 UTC 2017

Hi Frank --

Yes, I logged out and back in.  I had to because I couldn't stop X11 from repeatedly launching and dying otherwise!

When I run "port installed xorg-libXt" now I get exactly what you have.
501>> port installed xorg-libXt
The following ports are currently installed:
  xorg-libXt @1.1.5_1 (active)

But when I try to start xterm, X11 fails to launch, and keeps trying and failing until I log out, whether or not I kill the xterm.  Sometimes a dialog appears asking I really want to relaunch, but it keeps relaunching even if I tell it not to.

I don't have any problems running X11 with macports on a different computer.

-- Steve

From: macports-users <macports-users-bounces at lists.macports.org> on behalf of "mf2k at macports.org" <mf2k at macports.org>
Date: Tuesday, April 4, 2017 at 10:38 AM
To: "macports-users at lists.macports.org" <macports-users at lists.macports.org>
Subject: Re: X11 won't start

Hi Steve,

On Apr 4, 2017, at 8:27 AM, Langer, Stephen A. (Fed) <stephen.langer at nist.gov<mailto:stephen.langer at nist.gov>> wrote:

I just updated my computer to Sierra, and now X11 won't start.  I presumed that I had messed up the macports migration, so I just uninstalled everything and installed only xorg-server and xterm, but I'm still getting the same error.  There's an "X11 quit unexpectedly" dialog, which keeps reappearing when dismissed.  I have to log out to get it to go away.

System.log is filled with lines like "X[6012]: no path for address 0x1234567"

In case it's relevant, what I might have screwed up in the first migration was that I tried to install only the requested ports, which has worked for me in the past.  But this time I put them all on one line, and used -N so that port wouldn't ask me for permission to install the dependencies, and I could leave it to work on its own.  That ran into problems caused by https://trac.macports.org/ticket/49379.  It seemed to have installed xorg-libXt with +flat_namespace and then reinstalled it without it, or vice versa (both were installed but I forget which was active).  In any case, I uninstalled everything, installed xorg-libXt first, using +flat_namespace, and then installed all the other requested ports without -N so that I'd see if anything went wrong.  I didn't see any errors, but X11 wouldn't start.  This morning I tried installing only xorg-server and xterm, and it still won't start.

Why is X11 failing to start?  How can I keep it from attempting to start repeatedly, even after I've killed xterm or whatever other X11 app I'm using?  What might have I done wrong in the installation and how can I fix it?

Any suggestions would be appreciated!

Did you logout and log back in after re-installing xorg-server?

FYI, here is what I have installed for xorg-libXt on Sierra with working xorg-server.

$ port installed xorg-libXt
The following ports are currently installed:
  xorg-libXt @1.1.5_1 (active)


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.macports.org/pipermail/macports-users/attachments/20170404/a1632579/attachment.html>

More information about the macports-users mailing list