Permission denied writing temp file during restore_ports.tcl on macOS sierra

Kendall Shaw at
Thu Apr 20 22:45:54 UTC 2017

On 4/20/17, 3:38 PM, "Ryan Schmidt" <ryandesign at> wrote:

    > On Apr 20, 2017, at 11:30, Kendall Shaw < at> wrote:
    > Building gmp fails because it can’t write to a directory that it creates in /var/folders/xx/_blah/T:
    > :info:build make: error: couldn't create cache file '/var/folders/sr/_cb62lmn0v36cvbz11hjgy7r0000gn/T/xcrun_db-eQZtJHV5' (errno=Permission denied)
    > Changing permissions using chmod -R g+w  /var/folders/sr/_cb62lmn0v36cvbz11hjgy7r0000gn doesn’t change, it still creates a directory and then says it can’t write to it. And I’ve tried a few variations of this changing group and ownership 
    > Do you know what needs to be done?
Thank you. I had tried deleting the ‘T’ directory but not the parent. I’m not sure why the same problem didn’t happen again after removing and reinstalling macports.

I noticed that it used the same temporary directory name again after deleting the T directory, which seems odd, e.g. it used xcrun_db-eQZtJHV5 again.


More information about the macports-users mailing list