gtk3 from python3

petr.2006 petr.2006 at
Sat Feb 11 14:41:11 UTC 2017

Well, I tried uninstall everything and install again py35-gobject3.
Now it works better. Instead of the error, I got just warning:

pvmb:007 pet$ 2017-02-11 15:23:16.753 Python[96519:1552386] *** WARNING: Method userSpaceScaleFactor in class NSView is deprecated on 10.7 and later. It should not be used in new applications. Use convertRectToBacking: instead. 

( Gtk-WARNING **: Locale not supported by C library.
	Using the fallback 'C' locale.

( Gdk-WARNING **: GdkQuartzDisplay does not implement the monitor vfuncs

Running Python 3.5.3 on darwin

Another anoyancy is that in gtk.TreeView, triangles to unfold items are not shown.
Clicking on the place where the triangle should be the item unfolds anyway.
But it was an issue even before port version 2.4.0


> On 27 Jan 2017, at 20:46, petr.2006 <petr.2006 at <mailto:petr.2006 at>> wrote:
> After todays update, I am not able to use gtk3 from python3.5:
> pvmb:~ pet$ python
> Python 3.5.3 (default, Jan 27 2017, 20:18:08) 
> [GCC 4.2.1 Compatible Apple LLVM 8.0.0 (clang-800.0.42.1)] on darwin
> Type "help", "copyright", "credits" or "license" for more information.
>>>> import gi
>>>> gi.require_version('Gtk', '3.0')
> Traceback (most recent call last):
> File "<stdin>", line 1, in <module>
> File "/opt/local/Library/Frameworks/Python.framework/Versions/3.5/lib/python3.5/site-packages/gi/", line 122, in require_version
>   (namespace, version))
> ValueError: Namespace Gtk not available for version 3.0
> I tried to rebuild everthing using :
> sudo port upgrade --force py35-gobject3
> but this did not help.
> Any hint?

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the macports-users mailing list