nap doesn't like libc++ ?

Richard L. Hamilton rlhamil at
Wed Jul 12 16:10:44 UTC 2017

After switching my Snow Leopard over to the toolchain that supports C++11 and favors libc++ instead of libstdc++, I could no longer build nmap; it kept getting undefined symbols like std::logic_error::logic_error  (which as used, may be peculiar to libstdc++ instead).

On a hunch, I tried the plain old Apple compiler (configure.compiler=gcc), and it worked.

Not sure what's up with this, because I've never run into it before, either on Snow Leopard or on anything newer (El Capitan, Sierra).

Is nmap doing something that doesn't play equally nicely with both flavors of library, or what?  If so, should the Portfile be more specific about what it needs (compiler or library or whatever), so as to be less dependent on a particular macports.conf configuration or toolchain installation?

Here's what I've got configured:

sh-3.2# egrep 'default_compilers|cxx_stdlib' macports.conf
cxx_stdlib         libc++
default_compilers  macports-clang-3.9 macports-clang-3.7 macports-clang-3.4 gcc-4.2 apple-gcc-4.2 gcc-4.0

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 842 bytes
Desc: Message signed with OpenPGP
URL: <>

More information about the macports-users mailing list