`port self update` fails

Ryan Schmidt ryandesign at macports.org
Tue Mar 7 16:33:44 UTC 2017

> On Mar 7, 2017, at 09:32, Rasku, Stephen (GE Digital) <srasku at wurldtech.com> wrote:
> I am trying to do a “selfupdate” but it’s failing.

Has it ever worked?

> Note that our company may be blocking outgoing pings so that might explain the problematic ping/traceroute results.

Tell your company to fix that; that's broken and it will interfere with MacPorts being able to determine what server is closest to you for fastest service.

> I am able to get to rsync.macports.org but it re-directs to distfiles.macports.org.

rsync.macports.org is an rsync server, not a web server, so there's no reason to access it in a web browser. If you do, it will, for historical reasons, redirect to distfiles.

> Usually I am behind a proxy but I ran this test on our external network.
> Is there any way I can fix this?
> $ sudo port -d selfupdate 
> DEBUG: Copying /Users/212434537/Library/Preferences/com.apple.dt.Xcode.plist to /opt/local/var/macports/home/Library/Preferences
> DEBUG: MacPorts sources location: /opt/local/var/macports/sources/rsync.macports.org/macports/release/tarballs
> --->  Updating MacPorts base sources using rsync
> DEBUG: system: /usr/bin/rsync -rtzv --delete-after rsync://rsync.macports.org/macports/release/tarballs/base.tar /opt/local/var/macports/sources/rsync.macports.org/macports/release/tarballs
> rsync: failed to connect to rsync.macports.org: No route to host (65)

Consult your network administrator.

More information about the macports-users mailing list