Upgrade to Sierra from Mavericks

Mannucci, Anthony J (335G) anthony.j.mannucci at jpl.nasa.gov
Sun Mar 12 18:05:45 UTC 2017

I want to report an apparently smooth upgrade of macports when I upgraded my OS to Sierra from Mavericks.

I tried to follow the instructions<https://trac.macports.org/wiki/Migration> exactly, and found some minor issues:
1) The lack of a gfortran meant that install errors were found using the restore_ports.tcl script.
2) I manually installed gcc49 which created gfortran (almost).
3) I had to manually softlink the commands “gcc” and “gfortran” to the versions found in /opt/local/bin. Then “gcc" and “gfortran" were on my path.
3) I tested it by installing Atlas first, which worked.
4) The restore_ports.tcl reported the error below. It does not seem to have propagated to anything else. Further testing of the ports will reveal if there are any issues.

Instructions for installing command line tools of Xcode can be found here: http://railsapps.github.io/xcode-command-line-tools.html.
Just issue the command
xcode-select —install.

Part of the install output:
--->  Cleaning bzip2
--->  Fetching distfiles for cctools-headers
--->  Verifying checksums for cctools-headers
--->  Extracting cctools-headers
--->  Configuring cctools-headers
Error: cctools-headers has been replaced by libmacho-headers; please install that instead.
Error: Failed to configure cctools-headers: obsolete port
Error: See /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_devel_cctools-headers/cctools-headers/main.log for details.
--->  Cleaning cmsvlib

Thanks to the community for an overall smooth and successful process.


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.macports.org/pipermail/macports-users/attachments/20170312/06b455a0/attachment.html>

More information about the macports-users mailing list