Upgrade to Sierra from Mavericks

Mannucci, Anthony J (335G) anthony.j.mannucci at jpl.nasa.gov
Mon Mar 13 14:53:42 UTC 2017


I did not save which port wanted gfortran. Sorry. Before one executes “port select gcc” there is no executable named “gfortran”. The executables have specific version names. One of the ports was expecting the generic name “gfortran”.


Tony Mannucci
Supervisor, Ionospheric and Atmospheric Remote Sensing Group
 Mail-Stop 138-308,                     Tel > (818) 354-1699
 Jet Propulsion Laboratory,              Fax > (818) 393-5115
 California Institute of Technology,     Email > Tony.Mannucci at jpl.nasa.gov<mailto:Tony.Mannucci at jpl.nasa.gov>
 4800 Oak Grove Drive,                   http://scienceandtechnology.jpl.nasa.gov/people/a_mannucci/
 Pasadena, CA 91109

From: <dstrubbe at gmail.com<mailto:dstrubbe at gmail.com>> on behalf of David Strubbe <dstrubbe at macports.org<mailto:dstrubbe at macports.org>>
Date: Sunday, March 12, 2017 at 8:15 PM
To: Tony Mannucci <Anthony.J.Mannucci at jpl.nasa.gov<mailto:Anthony.J.Mannucci at jpl.nasa.gov>>
Cc: MacPorts Users <macports-users at lists.macports.org<mailto:macports-users at lists.macports.org>>
Subject: Re: Upgrade to Sierra from Mavericks

Can you explain more what you mean by this?

1) The lack of a gfortran meant that install errors were found using the restore_ports.tcl script.

I don't think there should be any port which tries to build using an executable called "gfortran". A port such as gcc49 installs gfortran-mp-4.9.


On Sun, Mar 12, 2017 at 6:03 PM, Ryan Schmidt <ryandesign at macports.org<mailto:ryandesign at macports.org>> wrote:

> On Mar 12, 2017, at 13:05, Mannucci, Anthony J (335G) wrote:
> I want to report an apparently smooth upgrade of macports when I upgraded my OS to Sierra from Mavericks.

Glad to hear it!

> I tried to follow the instructions exactly, and found some minor issues:
> 1) The lack of a gfortran meant that install errors were found using the restore_ports.tcl script.
> 2) I manually installed gcc49 which created gfortran (almost).

That's a very old version of gcc. The latest stable version is gcc6; I recommend using that instead.

> 3) I had to manually softlink the commands “gcc” and “gfortran” to the versions found in /opt/local/bin. Then “gcc" and “gfortran" were on my path.

Ok, but you're not meant to have to do that manually. Use "sudo port select gcc" to do it for you.

> 3) I tested it by installing Atlas first, which worked.
> 4) The restore_ports.tcl reported the error below. It does not seem to have propagated to anything else. Further testing of the ports will reveal if there are any issues.
> Instructions for installing command line tools of Xcode can be found here: [snipped non-official URL]

They can also be found in MacPorts documentation, and probably on Apple's web site somewhere.

> Just issue the command
> xcode-select —install.
> Part of the install output:
> --->  Cleaning bzip2
> --->  Fetching distfiles for cctools-headers
> --->  Verifying checksums for cctools-headers
> --->  Extracting cctools-headers
> --->  Configuring cctools-headers
> Error: cctools-headers has been replaced by libmacho-headers; please install that instead.
> Error: Failed to configure cctools-headers: obsolete port
> Error: See /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_tarballs_ports_devel_cctools-headers/cctools-headers/main.log for details.
> --->  Cleaning cmsvlib
> Etc.

cctools-headers is obsolete. Uninstall it / remove it from the list of ports that you're instructing MacPorts to reinstall.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.macports.org/pipermail/macports-users/attachments/20170313/0787f4e7/attachment.html>

More information about the macports-users mailing list