Installing MacPorts after OS upgrade

Ken Cunningham ken.cunningham.webuse at
Wed Oct 4 18:53:17 UTC 2017

please take a moment to check to make sure there is no copy of Availability.h in /usr/local/include  (and nothing else in /usr/local while you're there)



On 2017-10-04, at 10:36 AM, Lucas.Pettey at wrote:

> Hello everyone,
> My OS was recently upgraded by my local sys admin to Sierra. MacPorts was installed and running fine when I was using El Capitan. I now cannot get MacPorts to build or install from the package. I have confirmed that I have Xcode 9.0 installed and I have run the suggested commands for Xcode licenses, etc.
> The MacPorts-2.4.1-10.12-Sierra.pkg fails after trying to run package scripts. There is no information given as an error message. The installer tells me to contact the software provider. 
> I have tried building from the source files as well. This fails at the first build step. I am attaching the configure output. I have tried switching the the configure compiler to Xcode's cc, but I get the same error:
> ITLLRP-MN-21381:MacPorts-2.4.1 rditllrp$ ./configure > configure.txt
> configure: WARNING: GNUSTEP_SYSTEM_ROOT is not defined in your environment, preventing the use of GNUstep's Foundation library
> configure: WARNING: No ports tree found
> ITLLRP-MN-21381:MacPorts-2.4.1 rditllrp$ make
> ===> making all in vendor
> ===> making all in vendor/tcl/unix
> In file included from /Users/rditllrp/Downloads/MacPorts-2.4.1/vendor/tcl/unix/../generic/tclStubLib.c:14:
> In file included from /Users/rditllrp/Downloads/MacPorts-2.4.1/vendor/tcl/unix/../generic/tclInt.h:36:
> In file included from /Users/rditllrp/Downloads/MacPorts-2.4.1/vendor/tcl/unix/../generic/tclPort.h:23:
> In file included from ./tclUnixPort.h:622:
> /usr/include/pthread.h:423:25: error: expected parameter declarator
> __SWIFT_UNAVAILABLE_MSG("Use lazily initialized globals instead")
>                         ^
> /usr/include/pthread.h:423:25: error: expected ')'
> /usr/include/pthread.h:423:24: note: to match this '('
> __SWIFT_UNAVAILABLE_MSG("Use lazily initialized globals instead")
>                        ^
> /usr/include/pthread.h:424:51: error: expected ';' after top level declarator
>                                                   ^
> 3 errors generated.
> make[2]: *** [tclStubLib.o] Error 1
> make[1]: *** [all-tcl] Error 2
> make: *** [all] Error 1
> Any advice is appreciated. 
> Thanks,
> Lucas Pettey, PhD 
> <configure.txt>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the macports-users mailing list