On Snow Leopard, updating at-spi2-atk to @2.26.0_0+universal failed unless at-spi2-core updated first
ryandesign at macports.org
Tue Sep 12 19:30:21 UTC 2017
On Sep 12, 2017, at 13:58, Richard L. Hamilton wrote:
> Hardware Version: Mac mini (Mid 2007)
> Model Identifier: Macmini2,1
> Mac OS X 10.6.8 10K549 (Snow Leopard)
> Xcode 3.2.6 DevToolsSupport-1806.0
> MacPorts Version: 2.4.1
> The error in the log file seems to say as much:
> :info:configure checking for atk >= 2.25.2... no
> :info:configure configure: error: Package requirements (atk >= 2.25.2) were not met:
> :info:configure Requested 'atk >= 2.25.2' but version of Atk is 2.24.0
> :info:configure Consider adjusting the PKG_CONFIG_PATH environment variable if you
> :info:configure installed software in a non-standard prefix.
> :info:configure Alternatively, you may set the environment variables ATK_CFLAGS
> :info:configure and ATK_LIBS to avoid the need to call pkg-config.
> :info:configure See the pkg-config man page for more details.
> yet that was not done in the right order automatically. Why not? Is it new that at-spi2-stk configure checks the version of the prerequisite atk component(s)?
> I didn't use the -n option; the exact command I used was
> port upgrade outdated and not ( avahi or cppunit or libiodbc or nmap or qca or cdrtools or smake )
Sounds like at-spi2-atk 2.26.0 requires atk 2.26.0. MacPorts should have automatically upgraded atk to 2.26.0 before attempting to build at-spi2-atk. If it didn't, you can try updating atk first.
More information about the macports-users