MacPorts 2.4.3 has been released

Ryan Schmidt ryandesign at
Thu Apr 12 03:24:12 UTC 2018

On Apr 11, 2018, at 21:54, Joshua Root wrote:

> On 2018-4-12 12:39 , Ryan Schmidt wrote:
>> On Apr 11, 2018, at 10:23, Joshua Root wrote:
>>> No, rsync just hasn't updated yet. The ports are also a bit out of date.
>>> Ryan should be able to take a look before too long.
>> mprsyncup is failing with:
>> 2018-04-11T02:10:34+0000 error: pathspec 'v2.4.3' did not match any file(s) known to git.
> I guess GitHub changed something? That's the format we've been using
> since 2.3.5.

Maybe mprsyncup has not retrieved the new list of tags. We had that problem last time, and Rainer fixed it:

But I ran "git tag" in /Volumes/RAID/var/tmp/mprsyncup/release/base and it listed every tag up to v2.4.2 but not v2.4.3.

2018-04-12T03:16:17+0000 + read -r RELEASE_URL
2018-04-12T03:16:17+0000 + '[' -z ']'
2018-04-12T03:16:17+0000 + RBASE_CHANGED=1
2018-04-12T03:16:17+0000 + '[' -d /Volumes/RAID/var/tmp/mprsyncup/release/base/.git ']'
2018-04-12T03:16:17+0000 + cd /Volumes/RAID/var/tmp/mprsyncup/release/base
2018-04-12T03:16:17+0000 + /opt/local/bin/git fetch -q --tags
2018-04-12T03:16:18+0000 ++ /opt/local/bin/git rev-parse HEAD
2018-04-12T03:16:18+0000 + RBASE_OLD_REV=68708e1c5e2a4f21afa95e733c5d34cd0f5c71de
2018-04-12T03:16:18+0000 ++ /usr/bin/basename
2018-04-12T03:16:18+0000 + /opt/local/bin/git checkout -q v2.4.3
2018-04-12T03:16:18+0000 error: pathspec 'v2.4.3' did not match any file(s) known to git.

More information about the macports-users mailing list