wine-devel could not load binary

Ryan Schmidt ryandesign at
Sat Dec 22 20:35:21 UTC 2018

On Dec 22, 2018, at 08:41, Gijs Vermeulen wrote:

> I'm having issues with wine-devel since upgrading from 3.18 to 4.0rc2.
> When I run wine --help it works, but running anything else yields "/opt/local/lib/../bin/wine: could not load binary"
> My machine is a 2015 MacBook Pro running macOS High Sierra (fully updated).
> I have tried completely removing macports and installing everything again from scratch.
> I was wondering if anyone else has experienced this issue.

Yes, I see that too.

I guess this change from 4.0-rc1 might be related:

> What's new in this release (see below for details):
>   - Preloader implemented on mac OS.

I don't know anything else about the problem yet and I don't know what the "preloader" is. You might check if it's already been reported in the wine issue tracker. It's possible it has to do with the way we have moved the wine executable in order to use a wrapper script, in which case it's our bug, not theirs.

More information about the macports-users mailing list