smartctl - Can't run select span range

Ubence Quevedo (thatrat) thatrat at
Mon Jun 25 13:13:27 UTC 2018

Hi All,

I tried compiling the latest snapshot of smartmontools, and the problem is still occurring:
Ubences-MacBook-Pro:smartmontools-6.7 uquevedo$ ./smartctl -t select,0-10 /dev/disk0
smartctl 6.7 2018-06-21 r4735 [Darwin 17.6.0 x86_64] (local build)
Copyright (C) 2002-18, Bruce Allen, Christian Franke,

Sending command: "Execute SMART Selective self-test routine immediately in off-line mode".
   0                    0                   10
Command "Execute SMART Selective self-test routine immediately in off-line mode" failed: Unsupported SMART self-test mode

This seems more a problem for smartmontools…?  Might this be a problem similar to not being able to scan external drives for smart information in macOS?

I’m still curious if anyone has gotten the selective span scan to work in macOS...?


> On Jun 24, 2018, at 3:35 PM, Ubence Quevedo <thatrat at> wrote:
> Thanks for pointing this out, but the selective scan range for smartctl has never worked in previous versions available through macports from the last few years, I’m just now finally posting something about this.  I had worked around this by setting the sleep timeout on my Mac to a much longer timeout [three hours] so the whole drive [1TB] could be scanned on a long test.  From what I understand of the selective scan range, the range will be scanned, and when the next scan occurs, it’s scan the next range. 
> I’d really love for this feature to work so I don’t have to keep my system online all the time for scanning.
> Any suggestions on how to look into this further?Perhaps build smartmontools from source and test?  Has anyone gotten the selective range to work for scanning from installing smartmontools from macports?
> -Ubence
> On Sun, Jun 24, 2018 at 3:15 PM Joshua Root <jmr at <mailto:jmr at>> wrote:
> Ubence Quevedo wrote:
> > However, when I boot the same system off of Ubuntu 18.04 Live USB with the
> > same version of smartmontools [6.6], this command works properly:
> Just a note that Ubuntu does not actually have the same version as
> MacPorts. As your output shows:
> MacPorts:
> > smartctl 6.6 2017-11-05 r4594 [Darwin 17.6.0 x86_64] (local build)
> Ubuntu:
> > smartctl 6.6 2016-05-31 r4324 [x86_64-linux-4.15.0-20-generic] (local build)
> MacPorts has the 6.6 release, corresponding to svn r4594. Ubuntu has an
> svn snapshot from sometime after 6.5 but before 6.6, r4324. This is
> confirmed by the listed Ubuntu package version:
> < <>>
> - Josh

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the macports-users mailing list