ggrep in MacPorts

Fielding, Eric J (329A) eric.j.fielding at
Sat Jun 30 15:23:57 UTC 2018

I upgraded the OS on one Mac yesterday to OSX 10.13.5 and installed my usual MacPorts ports, including tcl (tcl @8.6.8_0+corefoundation+threads). I have been using the package Modules 3.2.10 for many years on my Mac systems, but I don’t find it in MacPorts. I tried to re-install Modules 3.2.10 from source but it was having trouble finding the correct libraries, so I looked around and found the new Modules 4.1.3 on SourceForge last updated this month. I downloaded that and tried to install, but it seems that the new 4.1.3 version is looking for “ggrep”:

checking for uname... /usr/bin/uname
checking for make... /usr/bin/make
checking for sed... /usr/bin/sed
checking for ggrep... not found
ERROR: ggrep could not be found

I have installed the GNU “coreutils” port in MacPorts, but it installs the GNU grep as /opt/local/bin/grep instead of “ggrep”. Is “ggrep” a new thing? I don’t remember seeing it before.


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the macports-users mailing list