gimp2 install

Ryan Schmidt ryandesign at
Wed Nov 14 20:05:49 UTC 2018

On Nov 14, 2018, at 11:26, Ulrich Wienands wrote:

> On Nov 14, 2018, at 12:31 AM, Ryan Schmidt wrote:
>> On Nov 13, 2018, at 20:33, Uli Wienands wrote:
>>> Ok, so I did upgrade tk. That went ok, sort of. In the process of upgrading tk it butchered several other ports ("found 61 broken files, 5 broken ports"). In the process of fixing those it ran aground trying to install zstd. As a result, my octave 4.2.1 is now kaput :-(.
>>> (Which explains why I do not routinely upgrade things. If it ain't broke don't fix it.)
>>> Anyway, pressing on with gimp2. xorg-xorgproto now does install. Eventually it dies at zstd again. (port installed does not list zstd so I do not appear to have an older version installed).
>> zstd is a new dependency of the tiff port as of version 4.0.10. It's optional, but I decided to enable it always, for simplicity. If this causes problems, we can change tiff's zstd support to a variant.
>> The log shows you're building universal on 10.6. That (specifically building the 32-bit part on 10.6) is indeed something that does not currently work for zstd. See

> Hmm… I did not specify +universal; I don’t need that.
> Do I “sudo port install gimp2 -universal” (minus universal) to suppress the apparent default?

You can run "sudo port install gimp2" to install gimp2 with the default set of variants, however that won't change the variants of its installed dependencies, such as tiff, so that won't solve the problem.

Universal is not the default; you or something requested it at some point. If you didn't ask for it by using "+universal" when installing tiff, then you may have installed a port that required tiff to be universal.

One common culprit is wine. It used to be 32-bit only, but even now that it includes 64-bit support, that 64-bit support requires the 32-bit parts, so it requires a universal build of itself and its dependencies. If you have wine installed, or if you at one point tried to install wine, that explains why MacPorts is trying to build you a universal tiff.

If you haven't used wine, then you may have installed (or tried to install) a port that is 32-bit only. If so, MacPorts would automatically install its dependencies universal. Those dependencies may have included tiff.

You could look through the list of ports that you've installed that are installed 32-bit only:

port -v installed | grep "'i386'"

For any ports listed by that command, you could check whether you still need that port, and if so, whether that port's dependencies include tiff. For example if you have the port "FOO" installed and you want to check if it depends on tiff:

port rdeps FOO | grep tiff

If it does, that explains why you need tiff universal.

If you've uninstalled all the 32-bit-only ports that need tiff, then you could look at any remaining ports that use the universal variant:

port installed | grep universal

There's now presumably no remaining need for those to be universal, and you could reinstall each of them without the universal variant.

More information about the macports-users mailing list