Problem with enscript

Dave Horsfall dave at
Fri Nov 16 00:21:13 UTC 2018

Sierra, latest Macports, GNU Enscript 1.6.6.

Some time ago I discovered that an upgrade (dunno what) had blown away all 
my crafted printer definitions, so "enscript" was no longer working; the 
error is "lpr: The printer or class does not exist".

I have defined the printer to be "laser-tc" i.e. a laser printer accessed 
via the USB port on my Time Capsule, and this has worked for ages.

The "lpr" command itsekf works fine, but when piped from "pr" looks ugly.

Running "enscript -v" shows nothing useful.

I tried to move /usr/bin/lpr aside to replace it with a shell script to 
echo its arguments, but:

     ozzie:/usr/bin [4]# mv lpr lpr.real
     mv: rename lpr to lpr.real: Operation not permitted
     ozzie:/usr/bin [5]# cp lpr lpr.real
     cp: lpr.real: Operation not permitted

so I guess the file system is protected somehow (even from root!).

If anyone here is using "enscript" can you please tell me how you got it 
going?  It worked OK here for years, until as I said all my printer 
definitions were suddenly blown away (reason unknown).


-- Dave

More information about the macports-users mailing list