segfault while building gimp

Riccardo Mottola riccardo.mottola at
Fri Nov 23 07:28:09 UTC 2018


I am trying to build gimp 2.10 on Leopard!
I did some further backports in gtk3 that could be enough. The main 
issue is that the native file chooser is heavily 10.6 stuff dependent, 
for now I tried to disable it, maybe better things can be done, but I 
don't think they should cause the issue below.

Why the surge? other than "the sake of it" it is an issue with gegl, 
since 2.8 depends on 0.2 and now we have 0.4

Anyway, gtk3 "installed", that's something. All the other dependencies 
I had to manually install gtk-doc, or gtk3 would not build/install, 
but I have seen on track a similar bug and worked around this way for 

I think gimp largely built (yay!) however, I do get this:

mkdir -p 24 && \
	../../tools/invert-svg ../../icons/Symbolic/24/gimp-warning.svg 
mkdir -p 24 && \
	../../tools/invert-svg ../../icons/Symbolic/24/gimp-web.svg 
mkdir -p 24 && \
	../../tools/invert-svg ../../icons/Symbolic/24/gimp-wilber.svg 
mkdir -p `dirname 64/gimp-error.png`; GEGL_USE_OPENCL=no GEGL_SWAP=ram 
/opt/local/bin/gegl-0.4 ../../icons/Symbolic/64/gimp-error.png -o 
64/gimp-error.png -- gegl:invert-gamma
/bin/sh: line 1: 52971 Bus error               GEGL_USE_OPENCL=no 
GEGL_SWAP=ram /opt/local/bin/gegl-0.4 
../../icons/Symbolic/64/gimp-error.png -o 64/gimp-error.png -- 
make[3]: *** [64/gimp-error.png] Error 138
make[3]: Leaving directory 
make[2]: *** [all-recursive] Error 1

"what" is segfaulting here??? it looks almost a shell tool si dying!
I would open a bug, but I don't know what is the issue here.


More information about the macports-users mailing list