`port install' from github tarball fails

Werner LEMBERG wl at gnu.org
Tue Sep 25 09:15:44 UTC 2018

[macports-base 60483e6e71054bcd741a55901c52117077ec7c43]

I'm working on a new Portfile for the `extractpdfmark' tool.  Within
the file I have

  github.setup        trueroad extractpdfmark 1.0.2 v
  github.tarball_from releases

After `port sync' I tried `port -v install' and I got

  --->  Attempting to fetch extractpdfmark-1.0.2.tar.gz from
  --->  Attempting to fetch extractpdfmark-1.0.2.tar.gz from
  Error: Failed to fetch extractpdfmark: The requested URL returned error: 404

Saying `curl --version' returns

  curl 7.61.1 (x86_64-apple-darwin11.4.2)
    libcurl/7.61.1 OpenSSL/1.0.2p zlib/1.2.11 libidn2/2.0.5
    libpsl/0.20.2 (+libidn2/2.0.5)
  Release-Date: 2018-09-05
  Protocols: dict file ftp ftps gopher http https imap imaps pop3
    pop3s rtsp smb smbs smtp smtps telnet tftp 
  Features: AsynchDNS IDN IPv6 Largefile NTLM NTLM_WB SSL libz TLS-SRP
    UnixSockets HTTPS-proxy PSL 

which looks OK to me.

Doing some manual tests with `curl' I tried

  curl -o x https://github.com/trueroad/extractpdfmark/releases/download/v1.0.2/extractpdfmark-1.0.2.tar.gz

which returned a `you are redirected' HTML document (attached).
However, adding the `-L' flag to curl (to follow redirections) makes
the program successfully download the tarball.

How shall I proceed?  It seems to me that I've hit a bug in


PS: Looking into the log file I see

      :notice:fetch --->  Attempting to fetch extractpdfmark-1.0.2.tar.gz
        from https://github.com/trueroad/extractpdfmark/releases/download/v1.0.2
      :debug:fetch Fetching distfile failed: error:1407742E:SSL
        routines:SSL23_GET_SERVER_HELLO:tlsv1 alert protocol version

    Maybe this is related also.
-------------- next part --------------
<html><body>You are being <a href="https://github-production-release-asset-2e65be.s3.amazonaws.com/64228231/86b73190-2303-11e7-84d6-107e81b23b3e?X-Amz-Algorithm=AWS4-HMAC-SHA256&X-Amz-Credential=AKIAIWNJYAX4CSVEH53A%2F20180925%2Fus-east-1%2Fs3%2Faws4_request&X-Amz-Date=20180925T090253Z&X-Amz-Expires=300&X-Amz-Signature=2262083b2212bc9e49efeca7a4c46092c3334e60a21ea016426cf135d084bd41&X-Amz-SignedHeaders=host&actor_id=0&response-content-disposition=attachment%3B%20filename%3Dextractpdfmark-1.0.2.tar.gz&response-content-type=application%2Foctet-stream">redirected</a>.</body></html>

More information about the macports-users mailing list