XTerm scrolling in xorg-server @1.20.4_0

Chris Jones jonesc at hep.phy.cam.ac.uk
Tue Apr 2 12:20:59 UTC 2019


Hmmm. xorg-server-devel has been on 1.20.x for a long time, and I have 
been running extensively for some time (12 months +) and not seen any 
issues. But then, I don't use xterm.... Now I have tried then yes, I see 
it too.

Does this only affect xterm, or have you seen any other issues with the 
server update ? You say "X11 is really painful to use now." but that is 
not my experience, I have to say. All my use cases worked without 
problems... If not, I would not have proposed the recent update to 


On 02/04/2019 12:28 pm, Michael Dickens wrote:
> This issue started with the prior "xorg-server-devel" bump a while back. I just moved to iTerm2 for the interim; -very- impressed with that terminal manager! I still need Xterm for some things though ... sigh ... - MLD
> On Mon, Apr 1, 2019, at 11:37 PM, Ken Cunningham wrote:
>>> Has anybody else noticed that text scrolling in a xterm is now glacially
>>> slow since xorg-server was upgraded to @1.20.4_0 over the weekend?
>>> X11 is really painful to use now.
>> It certainly is. There is something wrong with the screen redrawing in
>> xterm now, it seems.
>> Ken

More information about the macports-users mailing list