chilli.namesake at chilli.namesake at
Wed Feb 20 00:36:35 UTC 2019


A little embarrassing, but I need some direction. I realize macports user support does not really exactly support the port I need (ffmpeg), I have a feeling someone reading this will know what's up from the brief details I can provide. Please allow me to describe my situation, and where I think I went wrong. 

I am running snow leopard 10.6, and while I don't expect support to continue forever (if it wasn't ended some time ago here and nearly everywhere, though last I checked Apple still sold snow leopard server software, probably while supplies lasted), I expected to simply stop updating and allow the tools that always worked to freeze at whatever version, and continue working with them as long as possible. 

ffmpeg and a few other ports are critical to my scripts, and I broke ffmpeg, and can't rev-upgrade. I went a long time without upgrading, then upgraded some ports and everything seemed to work, blew away previous builds. Then on a subsequent upgrade of I think x265, ffmpeg broke. I read about a solution, which was to blow away x265 and rebuild it. That didn't work, though I believe x265 rebuilt, ffmpeg is still broken... the error should look familiar when I call ffmpeg, I get

> dyld: Library not loaded: /opt/local/lib/libvpx.5.dylib
>  Referenced from: /opt/local/bin/ffmpeg
>  Reason: image not found
> Trace/BPT trap

the rebuilds for ffmpeg fail with

> Error: Failed to fetch libsdl2: Building libsdl2 @2.0.9 on Mac OS X 10.6 requires the MacOSX10.7.sdk to be present in /Developer/SDKs/

So my understanding, if correct, is a dependency of the next (or current) rev of ffmpeg requires 10.7 SDK, which is never going to be present on my snow leopard box.

I don't need the current build of ffmpeg. Last build that worked... was fine. I don't know why I messed with it, but if I can get a working build, I'll just freeze my system and stop upgrading the ports. I would just restore a backup, but I've never restored a Time Machine back up of my system, and I'm not entirely sure I remembed to include  /opt in the backups, and they don't appear to be there.

I know there is one method... involving git I believe... that I don't have experience with... to check out... the right version that will build completely on 10.6 without trying to use a dependency I can no longer build. 

I don't want to waste anyone's time with my problems. I thought there might be someone still running snow leopard and ffmpeg subscribed to the list. If not, I would be grateful for some direction or perhaps a better understanding of just how deep my troubles run. And probably direct contact is ok to keep this bs off the listserv. Sorry for the bother, but I have no where else to turn (other than ffmpeg support, that I'd like to keep my problems far away from). All olutions to my previous build issues were solved here, and I wasted some time before I realized I had to ask for help. Thanks for any help provided comments, otherwise please ignore and carry on with the outstanding work.


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the macports-users mailing list