Group ID is 505 for files rsync'ed via selfupdate?

posita eb3f73+macports+org at
Thu Nov 7 15:42:21 UTC 2019

I have been wracking my brains trying to understand this, but have come up short.

Every time I do a `sudo port -c -u selfupdate`, many files in `<install_root>/var/macports/sources/` end up with GID 505. E.G.:

% ls -l <install_root>/var/macports/sources/
total 334112
-rw-r--r--   1 root  admin  13829383 Nov  7 04:55 PortIndex
-rw-r--r--   1 root  admin       512 Nov  6 21:24 PortIndex.rmd160
drwxr-xr-x  29 root  505         928 Oct 20 14:58 base
-rw-r--r--   1 root  admin  85712384 Oct 20 15:16 base.tar
-rw-r--r--   1 root  admin       512 Oct 20 15:16 base.tar.rmd160
drwxr-xr-x  62 root  505        1984 Nov  7 06:48 ports
-rw-r--r--   1 root  admin  71507456 Nov  7 06:37 ports.tar
-rw-r--r--   1 root  admin       512 Nov  7 06:37 ports.tar.rmd160

No group with ID 505 exists on my system. (`dscl . -search /Groups PrimaryGroupID 505` provides no output.) If I change the GID to `macports` (e.g., `sudo find <install_root> -group 505 -exec chgrp -v macports \{\} \;`), they’ll only be changed back on the next `selfupdate`. I tried digging into `<install_root>/etc/…` `<install_root>/var/macports/…` but didn’t see anything. I even tried reading the source code for `selfupdate`, but didn’t see what was going on there either. (Granted, I don’t know Tcl that well.)

Is this normal? Why 505? Is that configurable? Is it supposed to be something else? How do I change it?

Any help is greatly appreciated.

More information about the macports-users mailing list