dependency on correct openssl?

Ryan Schmidt ryandesign at
Sat Oct 5 13:21:45 UTC 2019

On Oct 4, 2019, at 21:41, Richard L. Hamilton wrote:

> I see that kdelibs4 and xmms2 are ok now; thanks to whoever did that (esp. kdelibs4, which is probably nasty to maintain).
> The one I have left that means I can't just "port upgrade outdated" on my system with the most packages installed, running the current (Mojave) OS, is vde2; a look at the log file makes it appear quite likely that's also an openssl changeover related problem.

I looked into vde2 a few days ago.

It is not compatible with openssl 1.1, as you found.

There is a newer version than the one we have in the port available, but it is years old and is also still not openssl 1.1 compatible.

This has been reported to the developers. Their response was to change their code so that it uses wolfssl instead of openssl. They have not yet released a new version containing this change.

I tried to update the port to the latest released version and backport the wolfssl change. Just getting that patch to apply required me to backport a number of other changes as well, and I don't think I ended up with a successful build after that either.

In the process, I noticed a half dozen other problems with their code. I reported these to the developers. I was intending to wait for them to acknowledge and hopefully fix those issues and release a new stable version so that I could then update the port to that version but so far they have not responded to those reports.

More information about the macports-users mailing list