MacPorts 2.6.2: Failed to configure postgresql83

Michael Newman mgnewman at
Wed Oct 23 05:01:09 UTC 2019

> On Oct 22, 2019, at 16:00, Ryan Schmidt <ryandesign at <mailto:ryandesign at>> wrote:
>> Yes, looks like nothing depended on postgresql83-server.

Except the Mac printing system.

After deleting postgresql83-server I can no longer print.

My printer has disappeared from the "Printers & Scanners System" Preferences and when I try to add the printer again, all the printer drivers have disappeared.

It’s hard for me to understand how the Mac printing system could depend on a database server installed via MacPorts, but it appears that’s the case.

I tried to reinstall postgresql83, but that failed with the same error that started this thread: Error: Failed to configure postgresql83: configure failure: command execution failed

Any ideas as to how to fix this?

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the macports-users mailing list