rspamd binaries fail with illegal instruction 4:

Horst Simon horst.simon at
Mon Sep 9 13:11:51 UTC 2019

I tried a build from source and it showed following for AVX

-- Performing Test C_HAS_AVX_1
-- Performing Test C_HAS_AVX_1 - Failed
-- Performing Test C_HAS_AVX_2
-- Performing Test C_HAS_AVX_2 - Success
-- Performing Test C_HAS_AVX2_1
-- Performing Test C_HAS_AVX2_1 - Failed
-- Performing Test C_HAS_AVX2_2
-- Performing Test C_HAS_AVX2_2 - Success

Will download the tar file and try with AVX disabled. I tried it on my iMac 2017 macOS 10.14.6 and it works fine on this one.

Horst Simon

> On 09 Sep 2019, at 21:47, Chris Jones <jonesc at> wrote:
> On 09/09/2019 12:35 pm, Horst Simon wrote:
>> Thanks for the replies, it is a Macbook Pro 2011 i try to run it on, 
> In which case I am going to bet the issue is your machine does not support avx2,  which the default build of rspamd apears to be enabling.
> One easy way to check is to force a build from source, and see what that does. The build should then detect what the build machine, your machine, supports and thus disable what is causing the problem.
> If that works, then please file a ticket at
> asking the maintainer or spamd to address the issue, by disabling the automatic CPU capabilities detection in the default builds.
> cheers Chris
>> will try the suggestions
>> Horst
>>> *Horst Simon*
>>> Mobile: +61 414 303-433 <tel:+61%20414%20303-433>
>>> Phone: +61 3 8555-2322 <tel:+61%203%208555-2322>
>>> Email: horst.simon at <mailto:horst.simopn at>
>>> ______________________________________________________________________
>>> Please consider your environmental
>>> responsibility before printing this email.
>>> This message (including any attachments) is intended only for the use of the individual or entity
>>> to which it is addressed and may contain information that is non-public, proprietary, privileged,
>>> confidential, and exempt from disclosure under applicable law or may constitute as attorney work
>>> product. If you are not the intended recipient, you are hereby notified that any use, dissemination,
>>> distribution, or copying of this communication is strictly prohibited. If you have received this
>>> communication in error, notify us immediately by telephone and (i) destroy this message if a facsimile
>>> or (ii) delete this message immediately if this is an electronic communication.
>> On 9 Sep 2019, at 20:57, Chris Jones <jonesc at <mailto:jonesc at>> wrote:
>>>> The first thing to do is check the buildbot logs, to see if you can work out what CPU feature the builds are enabling, and then proceed from there.
>>> from the 10.13 configure step
>>> -- Performing Test HAVE_AVX2_C_COMPILER
>>> -- Performing Test HAVE_AVX2_C_COMPILER - Success
>>> -- Compilation of avx asm set is supported
>>> -- Compilation of sse2 asm set is supported
>>> -- Compilation of sse3 asm set is supported
>>> -- Compilation of ssse3 asm set is supported
>>> -- Compilation of sse41 asm set is supported
>>> -- Compilation of sse42 asm set is supported
>>> -- AVX2 support is added
>>> -- AVX support is added
>>> -- SSE2 support is added
>>> -- SSE41 support is added
>>> -- SSE42 support is added
>>> enabling AVX(2) is likely the issue here, as this is not guaranteed to be available. My 2011 mac mini running 10.13 does not have AVX2, for instance.
>>> So the (default) build needs to be configured to not enable AVX, even if the host CPU (buildbot) supports it.
>>> Chris
>>>> Chris

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the macports-users mailing list