how use bash 5.0 port

Murray Eisenberg murrayeisenberg at
Mon Aug 31 17:22:11 UTC 2020

To get the MacPorts bash 5.0 the default shell, I now tried:

	- edit /private/etc/shells so as to add /opt/local/bin/bash

	- in System Preferences > Users & Groups, I opened Advanced Options for my (adminstrator’s) account and changed the entry for Login shell to /opt/local/bin/bash

	- rebooted

Still, when I open Terminal and issue command “echo $BASH_VERSION” I get response:  3.2.57(1)-release

Note: if in that apparent 3.2.57 shell in Terminal, if I give command “bash” then of course I get response 5.0.17(1)-release

> On 31 Aug2020, at 12:32 PM, Murray Eisenberg <murrayeisenberg at> wrote:
> I want to upgrade the built-ub bash 3.2 shell on my macOS Catalina (10.15.6) to bash 5.0.
> I tried to do this by building from scratch, using the methods given at <>. But the final step, “sudo make install” gave a fatal error of ‘libintl.h’ file not found.
> So then I successfully installed the MacPorts port bash @5.0.17_0.
> —> But how do I make this bash 5.0 my shell when I open Terminal?

Murray Eisenberg			murrayeisenberg at
503 King Farm Blvd #101	Home (240)-246-7240
Rockville, MD 20850-6667	Mobile (413)-427-5334

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the macports-users mailing list