Why are my por definitions still out of date after this?

Gerben Wierda gerben.wierda at rna.nl
Sat Feb 22 13:39:57 UTC 2020

> On 22 Feb 2020, at 13:32, Christopher Jones <jonesc at hep.phy.cam.ac.uk> wrote:
> Have you told macports to use your git clone ?
> i.e. 
>  > cat /opt/local/etc/macports/sources.conf
> <snip>
> #rsync://rsync.macports.org/macports/release/tarballs/ports.tar <rsync://rsync.macports.org/macports/release/tarballs/ports.tar> [default]
> file:///Users/chris/Projects/MacPorts/ports <file:///Users/chris/Projects/MacPorts/ports> [default]
> where for me /Users/chris/Projects/MacPorts/ports is my local git clone.


rsync://rsync.macports.org/macports/release/tarballs/ports.tar [default]

> b.t.w. Once you have done this, you don’t need to run all the git commands below. just running
> > sudo port sync
> will update your git clone, and run the portindex, for you.

With rsync, not with git. So what about branches etc? Suppose I create a branch in my fork to work in? And I want update my master to reflect the latest situation of the official repo?


> Chris
>> On 22 Feb 2020, at 11:43 am, Gerben Wierda <gerben.wierda at rna.nl <mailto:gerben.wierda at rna.nl>> wrote:
>> I have my own fork of the macports-ports repository on GitHub so I can do maintenance. I have a local clone of that fork
>> When I want to update ports I do not maintain, do the following. First I make sure my clone is up to date with the upstream original, then I push the clone back to my GitHub fork. Then I run portindex. ‘upstream’ is the official repo, origin is my fork
>> git fetch upstream
>> git checkout master
>> git reset --hard upstream/master
>> git push origin master --force
>> portindex
>> But when I do that, I still get:
>> albus:macports-ports sysbh$ port list updated
>> Warning: port definitions are more than two weeks old, consider updating them by running 'port selfupdate'.
>> (Should have said ‘outdated’ of course, this doesn’t give me a warning)
>> But port self update overwrites everything using rsync and doesn’t go via git. So, it is a parallel and possibly trouble-creating route. I want update my local tree entirely via git.
>> Still, with a clean clone of of an up-to-date fork, I can do it:
>> sudo port selfupdate
>> Password:
>> --->  Updating MacPorts base sources using rsync
>> MacPorts base version 2.6.2 installed,
>> MacPorts base version 2.6.2 downloaded.
>> --->  Updating the ports tree
>> --->  MacPorts base is already the latest version
>> What is the way to go when updating, using your own clone of your own fork of the git repo?
>> G

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.macports.org/pipermail/macports-users/attachments/20200222/1d9d10e0/attachment.html>

More information about the macports-users mailing list