opensp fails to build ==> fix

Ken Cunningham ken.cunningham.webuse at
Tue Feb 25 02:07:46 UTC 2020

:info:build ../include/Ptr.h:72:11: error: ISO C++11 does not allow access declarations; use using declarations instead
:info:build   Ptr<T>::isNull;

clang-9.0 (the current 10.6.8 default) is incredibly strict. Far stricter than any current Xcode compiler.

having said that, when I just tried, it downloaded a prebuilt binary from the buildbot:

$ port -v installed opensp
The following ports are currently installed:
 opensp @1.5.2_2 (active) platform='darwin 10' archs='x86_64' date='2020-02-24T17:59:26-0800'

trying to force a build, I get the same error as you do.

Your best bet, usually, is to try to use a more reasonable compiler. 

clang-5.0 is pretty close to what the current Xcode compilers are like, in terms of strictness and severity, and indeed, clang-5.0 build this software quite easily, but with a lot of warnings, of course.

sudo port -v install opensp configure.compiler=macports-clang-5.0

during periods of frustration, I have been known to set my default compiler in macports.conf to macports-clang-5.0 when I get too tired of these issues.



More information about the macports-users mailing list