X11 no longer working

Pierre Malard plm at teledetection.fr
Sat May 9 09:15:46 UTC 2020

Ok, everything seems to be Ok in the target side!

> Le 9 mai 2020 à 09:04, Christoph Kukulies <kuku at kukulies.org> a écrit :
> Here is the output. Nothing happens on the macOS side. I remembered that X11 (Quartz) popped up automatically iin the dock and the xclock appeared on the Mac desktop, last time it worked.

A last test is to launch X11 « by the hand » on terminal and look if the XQuartz is really launched:
	$ /Applications/Utilities/XQuartz.app/Contents/MacOS/X11

I remember I had some problems with XQuartz since Catalina upgrade.
There has been no XQuartz update since 2016 and they indicate another solution to have X11 on Mac OS X: MacPorts (https://www.xquartz.org/releases/index.html).

So I have switched to MacPorts install and I have no problems with Catalina.

Other thing, take a look on this URL: https://askubuntu.com/questions/1029909/x11-forwarding-for-non-root-user-not-working

> <log.txt>
> The X11DisplayOffset seems to be 10, although the line in sshd_config is commented out. 10 seems to be the default. But it used to work the day before yesterday. Don’t know what happened unless I had done something to the PATH or macports tree.
> What I did was remove the X11 icon from the dock, but that after it stopped working. It is so that X11 Quartz normally launches automatically when a client requests an X11 connection, right?
> Still clueless. Maybe I’m overlooking something very obvious?
>> Christoph
>> Am 08.05.2020 um 17:41 schrieb Pierre Malard <plm at teledetection.fr>:
>> Hi,
>> Some possibilities:
>> 1) Try your « ssh -Y » in verbose mode like « ssh -v -Y » or
>>  « ssh -vv -Y » for more verbose and take a look at the displayed
>>  messages.
>> 2) Is « xauth » package is on your target?
>> 3) What about the « X11DisplayOffset » on your target?
>> 4) What about these lines:
>> 	Source% ssh -Y user at cible
>> 	Target% echo $DISPLAY
>> 	Target% xclock
>> It’s not an SHELL problem.
>> Good luck
>>> Le 8 mai 2020 à 16:10, Christoph Kukulies <kuku at kukulies.org> a écrit :
>>> Today is a havoc day. I changed my login shell to bash. Also added this BASH Silencing variable succesfully.
>>> Was playing around for hours with my FreeBSD system in the network and in the morning I ran some X clients.
>>> Alway saw the X11 Quartz icon in the dock.
>>> Is it correct, the X server starts automatically if an X cient wants to connect over the network, right.
>>> Last thing I did was to remove the X11 icon from the dock. Now suddenly when I ssh -Y to the FreeBSD system, start xclock there,
>>> nothing happens. The xclock command line hangs on the client side. But no message at all. DISPLAY is localhost:10.0.
>>> I did a reboot of the FreeBSD system already to no avail. What’s going on? Will reboot my Mac and next thing I’ll do is revert to zsh to see whether it has got to do with that.
>>>>>> Christoph
>> --
>> Pierre Malard

Pierre Malard

   «Mittler zwischen hirn und händen muss das hirz sein !»
   «La médiation entre le cerveau et les mains doit être le cœur !»
                                                 Fritz Lang - "Métropolis" - 1929
   |\      _,,,---,,_
   /,`.-'`'    -.  ;-;;,_
  |,4-  ) )-,_. ,\ (  `'-'
 '---''(_/--'  `-'\_)   πr

perl -e '$_=q#: 3|\ 5_,3-3,2_: 3/,`.'"'"'`'"'"' 5-.  ;-;;,_:  |,A-  ) )-,_. ,\ (  `'"'"'-'"'"': '"'"'-3'"'"'2(_/--'"'"'  `-'"'"'\_): 24πr::#;y#:#\n#;s#(\D)(\d+)#$1x$2#ge;print'
- --> Ce message n’engage que son auteur <--

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 901 bytes
Desc: Message signed with OpenPGP
URL: <http://lists.macports.org/pipermail/macports-users/attachments/20200509/84df4b99/attachment.sig>

More information about the macports-users mailing list