Processes getting wedged in "U" (uninterruptible wait) state after Security Update 2020-003

Greg Earle earle at isolar.DynDNS.ORG
Thu May 28 23:25:23 UTC 2020

Hi all,

Kind of a long shot here, but given the level of Mac expertise on this 
list ...

At work I have a production Mac mini running macOS Mojave 10.14.6.  It 
ran perfectly fine - with several MacPorts ports in regular use - until 
last night.

I made the mistake of installing Security Update 2020-003.

After the reboot I started noticing things going haywire quickly.

- Servers that were running but not listening on their usual ports (or 
at all)

- Servers that were running normally but could not be killed (not even 
kill -9)

- Processes (including MacPorts apps) that get wedged as soon as they 

The common thread through all these is that the processes - whether you 
tried to kill them or run them from scratch - all get wedged in "U" 
(uninterruptible wait) state.  (Nothing is NFS or CIFS mounted so I 
doubt it's due to disk I/O.)

For example:

A COTS product we have uses Postgres as the back-end database; the 
Postgres server starts at boot time, but it doesn't bind to its normal 
listening port.  If I try to kill the process, it wedges - just like 
these other ones do.

If I try to run MacPorts' "htop" port ("/opt/local/bin/htop") - it 
immediately wedges.  I can't even run it under "dtruss" - I get no 
output at all, like as if it never even gets off the ground to run.

(Strangely, the normal system "top" runs fine and doesn't wedge - it 
also shows these processes as being in "stuck" state, as expected.)

If I try to restart MacPorts' Xymon monitoring port (which has several 
persistent processes started at boot time), one of them, "xymonlaunch", 
won't quit and it gets wedged in "U" state.

I was able to use "gcore" to get a core dump of one of the wedged 
processes, but when I tried to use the MacPorts "gdb" 
(/opt/local/bin/ggdb) to examine it, you guessed it ... instantly 

In fact, pretty much EVERYTHING in the MacPorts "/opt/local/bin" 
directory is wedging on me at startup!  I'm completely baffled at this 

Tried running the MacPorts "tree" and "openssl" next.  Stuck.

The list of wedged processes is getting impressive:

whdmac:~ root# top -l 1 | egrep STATE\|stuck | sed -e 
's/stuck.*/stuck/g' -e 's/STATE.*/STATE/g' -e 's/     //g'
Processes: 152 total, 2 running, 5 stuck
993   openssl     0.0  00:00.00 1   0   0     8192B+ 0B 0B    993  1    
973   tree        0.0  00:00.00 1   0   0     8192B+ 0B 0B    973  445  
956   htop        0.0  00:00.00 1   0   0     8192B+ 0B 0B    956  1    
261   xymonlaunch 0.0  00:00.00 1   0   0     8192B+ 0B 0B    246  246  
100   dbus-daemon 0.0  00:00.00 1   0   0     8192B+ 0B 0B    100  1    

I'm resigned to probably having to boot it into Recovery Mode and 
restore the system from a pre-Security Update 2020-003 Time Machine 
backup, but I thought I'd run it up the flagpole here first just to see 
if I was the only person in the world experiencing this.  Maybe this Mac 
is possessed ...

		- Greg

More information about the macports-users mailing list