Missing Dependency for py37-astropy

Sean Lake odysseus9672 at gmail.com
Thu Nov 26 01:49:08 UTC 2020

Hello all,

I just upgraded py37-astropy to version 4.2 and I now get the
following error when I try to run a script:

ImportError: erfa version 1.7 or later must be installed to use
Astropy. erfa is not installed.

Also, py36-astropy version 4.2 is just plain broken. When I try to run
a script usinig python 3.6 that calls that version of astropy I get
the error:

astropy.UnsupportedPythonError: Astropy does not support Python < 3.7

So that should probably be downgraded.

Sean Lake

More information about the macports-users mailing list