Catalina xcode-select --install and MacPorts installation

Fielding, Eric J (US 329A) eric.j.fielding at
Wed Oct 28 07:31:45 UTC 2020

I just upgraded my MacBook to Catalina 10.15.7 from 10.14.6 and I installed the latest Xcode 12.1. I started Xcode and agreed for it to install required components. When I tried to run “xcode-select –install” it asked me to agree to the license for the command-line tools and tried to install but then said “Can’t install the software because it is not currently available from the Software Update server.” I went to the Software Update control panel and it said that it had an update for my command-line tools, and I told it to go ahead and update them. After a while, it said that the command-line tools are no longer required or something like that.

I decided to go ahead and try to install MacPorts with the Catalina MacPorts installer and it showed me the license, asked about the installation type and destination, but then when it got to the install step it says “Waiting for other installations to complete”. I don’t think I have any other installations still going on. Wait, after twenty minutes, it now says it is “running package scripts” and then finished. I guess it was installing something after all.

Maybe the Xcode installation instructions need an update for Catalina?

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the macports-users mailing list