selfupdate failing with "Operation timed out"

Joseph Hunkeler jhunkeler at
Fri Apr 23 00:25:37 UTC 2021


After installing MacPorts-2.6.4-10.15-Catalina.pkg I'm seeing this behavior:

# /opt/local/bin/port -v selfupdate
--->  Updating MacPorts base sources using rsync
rsync: failed to connect to Operation timed out (60)
rsync error: error in socket IO (code 10) at /AppleInternal/BuildRoot/Library/Caches/
Command failed: /usr/bin/rsync -rtzvl --delete-after rsync://
Exit code: 10

# uname -r

# sw_vers
ProductName:	Mac OS X
ProductVersion:	10.15.7
BuildVersion:	19H524

I've tried setting "rsync_server" in /opt/local/etc/macports/macports.conf to a couple different hosts listed on but was
met with the error above. Is there something wrong on my end? How could every rsync server be down at the same time? I'm able to download files from the HTTP
servers for each mirror I've tried, so I'm a little baffled by this.

Is there another sync method I can try or does MacPorts only support rsync?


More information about the macports-users mailing list