What is up with perl5.26 on Snow Leo?

Ryan Schmidt ryandesign at macports.org
Wed Dec 1 06:09:18 UTC 2021

On Nov 29, 2021, at 20:21, Uli Wienands wrote:

> Well, I wonder whether someone did something within the last day or two. I just tried it again, and lo-and-behold, perl5.26 installed just fine & now MacPorts is getting to work on the backlog of things that I could not update because of this problem.
> This after I just found out (in debug mode) that the perl5.26 port actually was not able to get its files; the fetch errored out with a 404 error for all attempts. What is odd is that it proceeded to do a bunch of things after that & even went to the destroot phase. I would love to send the log, but the renewed attempt was to generate the log so I could pack it up & send it, only for now the install succeeded making this moot.
> So, my thanks go out to whomever fixed this.

Yes thanks very much to Josh who fixed it here:


There had also been a ticket about it:


No need for a log since the problem is solved.

What you presumably mean is that MacPorts encountered a 404 error trying to download a precompiled archive, and therefore it fetched the source (or MacPorts had already fetched the source for you before) and built it from source on your system. This isn't odd; it's how MacPorts is designed to work. A precompiled archive may simply not have been produced yet at the time you tried to install it. The archive has been produced now (you can see at http://packages.macports.org/perl5.26/ that they were built for darwin 10 on 11/28 at 10 am (x86_64) and 7 pm (i386) UTC), so if you were to try to install it now, you should receive that archive instead of needing to build from source.

More information about the macports-users mailing list