Trouble with upgrade outdated

Ryan Schmidt ryandesign at
Fri Dec 10 17:24:01 UTC 2021

On Sep 28, 2021, at 15:31, Tobias Welti wrote:

> I have trouble using port upgrade outdated since a few weeks ago. I just receive the following message:
> =======
> $ sudo port upgrade outdated
> Error: python39: Error executing universal: can't read "configure.sysroot": no such variable
> Error: Unable to open port: Error evaluating variants
> Error: Follow to report a bug.
> =====
> I have already tried to select the python3 version to python39, which completes without error. But the behaviour of upgrade outdated remains the same.
> Is there a known fix to this?

Sorry for the late response to this. If you are still seeing this problem, I'd suggest first making sure you have the latest version of MacPorts, 2.7.1. Run `port version` to find out. Run `sudo port selfupdate` to upgrade MacPorts and the portfiles. If you still get the configure.sysroot error when upgrading outdated ports, get the debug output by using the `-d` flag: `sudo port -d upgrade outdated`, and show us the output of that. Hopefully that might shed some light on why it's happening.

More information about the macports-users mailing list