Re: I am getting "the MacOS 11.2 SDK does not appear to be installed" warning — have manually installed Xcode 12.4 command-line tools

Ryan Schmidt ryandesign at
Thu Feb 11 02:09:57 UTC 2021

On Feb 10, 2021, at 01:02, Gregory Dodwell wrote:

> I have also followed all of the other recommendations outlined on the Macports webpage for the same issue ... to no avail once I start running "sudo port install ..." commands. 
> M1 Macbook Pro; OS 11.2.1; Macports v2.6.4.
> I run from my general account as a sudoer.
> I have downloaded the Xcode 12.4 command line tools from Apple Developer, and have run the recommended licence activation commands as privileged user. I still get the warning ...

Ignore this message for now, since there is no released version of Xcode that contains the 11.2 SDK. In the future, when you once again have a version of Xcode that contains an SDK version that matches your OS version, pay attention to it again. A future version of MacPorts will change how it checks for your SDK and will allow minor version matches.

More information about the macports-users mailing list