macOS 11.1 SDK not installed?

Baron Fujimoto at
Thu Jan 7 20:11:06 UTC 2021

I recently upgraded on of my systems to MacOS 11.1 (Big Sur), and subsequently upgraded MacPorts as well. However, when I attempt to upgrade my outdated ports with my usual 'sudo port upgrade outdated', the builds fail with the following being logged:

:debug:sysinfo macOS 11.1 (darwin/20.2.0) arch i386
:debug:sysinfo MacPorts 2.6.4
:debug:sysinfo Xcode 12.3
:debug:sysinfo SDK 11.1
:debug:sysinfo MACOSX_DEPLOYMENT_TARGET: 11.1
:warn:archivefetch The macOS 11.1 SDK does not appear to be installed. Ports may not build correctly.
:warn:archivefetch You can install it as part of the Xcode Command Line Tools package by running `xcode-select --install'.

If I run 'xcode-select --install' I get the error:

xcode-select: error: command line tools are already installed, use "Software Update" to install updates

I've tried reinstalling both Xcode and the Xcode command line tools from scratch to no avail.

I've similarly upgraded to Big Sur and MacPorts on another system and it works as expected.

Any suggestions would be appreciated.

More information about the macports-users mailing list