XQuartz and xorg-server

Peter West lists at pbw.id.au
Thu Jan 21 09:59:42 UTC 2021

Looking at the autoconf m4 files from /opt/local/share/autoconf/autoconf, I find two with lists of X11. autoconf.m4f, a generated file, and libs.m4, from which I assume autoconf.m4f was generated, have the following lists of X11 directories.







No /opt/local directories here. Is this a limitation that can be overriden in arguments to configure? I tried

autoconf -B /opt/local/include/X11 -B /opt/local/lib

but the configure comes out the same size, and when run tells me X11 not found.

Does the libs.m4 need to be tweaked?


> On 21 Jan 2021, at 9:32 am, Peter West <lists at pbw.id.au> wrote:
> I tried specifically building rgl from source. The source is available at https://cran.r-project.org/src/contrib/rgl_0.104.16.tar.gz.
> In R.app console, remove rgl package.
> > remove.packages(“rgl”)
> > install.packages(<path-to-source.tar.gz>, repos = NULL, type = “source”)
> It doesn’t find X, so it skips OpenGL; configure in the source needs tinkering.
> Peter
> --
> Peter West
> pbw at pbw.id.au
> “So the Son of Man is lord even of the Sabbath..”
>> On 19 Jan 2021, at 4:38 pm, Peter West <lists at pbw.id.au> wrote:
>> $ sudo port install xorg-server
>> $ sudo port install R
>> $ sudo port install R-app
>> Start MacPorts>R.app
>> In the R.app console
>> > install.packages(“rgl”)
>> This will involve a lot of compilation. The OpenMP problem seems to have been resolved by using the compiler /opt/local/bin/clang++-mp-9.0, and you will see plenty of this.
>> When that finishes, in the console
>> > library(rgl)
>> I get
>> This build of rgl does not include OpenGL functions.  Use
>>  rglwidget() to display results, e.g. via options(rgl.printRglwidget = TRUE).
>> So I should get output that way, but I’m curious about the “native” way of doing it.
>> Peter
>> --
>> Peter West
>> pbw at pbw.id.au
>> “So the Son of Man is lord even of the Sabbath..”
>>> On 19 Jan 2021, at 12:58 pm, Ryan Schmidt <ryandesign at macports.org> wrote:
>>> On Jan 18, 2021, at 04:56, Peter West wrote:
>>>> I’ve removed XQuartz (again), and installed R and R-app from MacPorts. The R install warned me that
>>>> Clang compilers provided by Xcode do not support OpenMP. Some R packages using OpenMP may require additional
>>>>  flags in the Makevar file (e.g. data.table) to build. Please consult package documentation.
>>>> I install.package’d data.table without whinging, then did the same for rgl. It built, but when I loaded the library, I was informed that
>>>> This build of rgl does not include OpenGL functions.
>>>> Looking around for mentions of OpenGL, I couldn’t se anything that looked like an OpenGL library.
>>> I don't know anything about R or rgl. I tried "port search rgl" and I'm not sure if any of those are what you're referring to.
>>> If you can provide an exact step-by-step list of commands to run to observe the problem, then I could try them on my system and see if I can figure out what needs to be changed.

Peter West
pbw at pbw.id.au
And whenever the unclean spirits saw him, they fell down before him and cried out, “You are the Son of God.”

More information about the macports-users mailing list