"port install meld" does not yield working executable

joerg van den hoff veedeehjay at gmail.com
Wed Mar 17 12:04:07 UTC 2021

On 17.03.21 12:39, Ryan Schmidt wrote:
 > On Mar 17, 2021, at 06:36, joerg van den hoff wrote:
 >> On 17.03.21 11:07, Ryan Schmidt wrote:
 >>> I think there is something wrong with your /opt/local/share/gir-1.0/GtkSource-4.gir. 
Specifically in mine, there is the line:
 >>> shared-library="/opt/local/lib/libgtksourceview-4.0.dylib"
 >>> and I think in yours the line is different. And I think it's this bug:
 >> and I think you are very right :). indeed, that line in my case reads (surprise!)	
 >> shared-library="./gtksourceview/libgtksourceview-4.0.dylib"
 >>> https://trac.macports.org/ticket/61792
 >>> and this bug:
 >>> https://trac.macports.org/ticket/62391
 >>> I think gobject-introspection is just broken for the moment. (Or it is fixed but we forgot to 
revbump all the affected ports to rebuild them.)
 >>> I guess you could manually edit affected .gir files to fix the shared-library paths to be the 
correct absolute ones.
 >> unfortunately, that does not help. I still get the " Failed to load shared library 
'./gtksourceview/libgtksourceview-4.0.dylib' referenced by the typelib: 
dlopen(./gtksourceview/libgtksourceview-4.0.dylib, 9): image not found" error --  despite having 
fixed the/opt/local/share/gir-1.0/GtkSource-4.gir to provide
 >> shared-library="/opt/local/lib/libgtksourceview-4.0.dylib
 >> and grepping through the other gir-files in that location seems to indicate that this is the 
only reference to that dylib file :|.
 >> so still no luck...
 >> I don't know about this stuff (gobject-introspection): is it required to reboot or restart some 
process to make changes to the gir file effective? right now it seems `meld' gets that relative path 
all the same or from somewhere else....
 > I don't really know either. But if changing the path in the gir file didn't fix the problem, then 
maybe it only looks at that at build time, in which case maybe you need to rebuild meld (sudo port 
-ns upgrade --force meld) and/or other ports in the dependency chain that use gir-based libraries. 
Before you do a lot of rebuilding, you might want to check if any other gir files in that directory 
have similarly-wrong shared-library lines that should be fixed first.
grep 'shared-library.*\.\/' *.gir

yielded only that single file/line containing a path relative to `./' (prior to fixing it).

and sadly even `sudo port -ns upgrade --force meld)' does not solve the problem...

too bad. but I appreciate your help. at least I now understand where approximately the problem is 
located ...

More information about the macports-users mailing list