[Solved]: clang: error: invalid version number in 'MACOSX_DEPLOYMENT_TARGET=11.3'

lars.sonchocky-helldorf at hamburg.de lars.sonchocky-helldorf at hamburg.de
Sat May 1 16:41:29 UTC 2021

> Am 01.05.2021 um 12:21 schrieb Joshua Root <jmr at macports.org>:
>> I’ve got a brand new MBP 16’’ from my employer and tried to use MacPorts on that.
>> Since it is so new it sports macOS Big Sur 11.3 and Xcode 12.5
>> I know both are very recent and came out just a couple of days ago, so I am not expecting the impossible.
>> Installing MacPorts itself went flawlessly but when I tried to install some ports (git, ImageMagick, … I gave up after those failed) I got the same error repeatedly:
>> clang: error: invalid version number in 'MACOSX_DEPLOYMENT_TARGET=11.3‘
>> is this error already known and is it even a MacPorts error, e.g. should I file a bug report?
> This usually indicates that your Command Line Tools are outdated. If Software Update won't update them, you are affected by an Apple bug, and will need to follow the instructions here: <https://trac.macports.org/wiki/ProblemHotlist#reinstall-clt>
> - Josh

Thanks Josh, that was the right hint! I did the following:

	• touch /tmp/.com.apple.dt.CommandLineTools.installondemand.in-progress
	• softwareupdate -l
	• ​Run Software Update
	• rm /tmp/.com.apple.dt.CommandLineTools.installondemand.in-progress

and everything went fine from there on!



More information about the macports-users mailing list